Motive 2.1 beta is now available. Please check the documentation versions on the sidebar.

Toolbar / Command Bar


(Redirected from Toolbar)

Main pageMotive DocumentationToolbar / Command Bar

Page Scope

This page lists out the options that are available on the toolbar and the command bar of Motive.

Motive Command Bar
The Motive Toolbar

Toolbar[edit]


The Motive Toolbar
Icon Function Description
Toolbar Open 20.png
Open File Open Motive files: Project (TTP), Calibration (CAL), Takes (TAK), Rigid bodies (TRA), Skeletons (SKL).
Toolbar Save 20.png
Save Current Take Save currently opened Take.
Toolbar SaveAll 20.png
Save All Takes Save all of the Takes that are loaded in the Data Management pane.
Toolbar AppSettings 20.png
Application Settings Opens Application Setting pane for software preferences. Reconstruction settings will also be modified in this pane.
Tb8.png
Hide all panes Closes all the panes in the layout, leaving only the main view port.
Toolbar Device Icon.png
Devices pane Opens the Devices (Cameras) Pane
Toolbar Calib 20.png
Calibration pane Opens Calibration Pane
Toolbar Data Icon.png
Data Management pane Opens the Data Management pane for managing takes.
Toolbar Assets Icon.png
Assets pane Opens the Assets pane for managing the list of tracked assets as well as integrated devices such as force plates and data acquisition devices.
Toolbar Properties Icon.png
Properties pane Opens the Properties pane for managing the properties of selected items in Motive.
Toolbar RigidBody .png
Rigid Body Properties pane Opens Rigid Body Properties.
Tb15.png
Skeleton pane Opens the Skeleton Pane for creating Skeletons. Available only in Motive:Body.
Toolbar Markerset Icon.png
Markersets pane Opens the Markersets pane for creating and configuring markersets.
Toolbar Timeline Icon.png
Timeline pane Opens the Timeline pane.
Tb19.png
Edit Tools Pane Opens Edit Tools for post-processing pipelines.
Toolbar Labeling Icon.png
Labeling pane Opens the Labeling pane for labeling the markers.
Toolbar GraphViews Icon.png
Graph View pane Opens Graph View pane for monitoring the channel data.
Toolbar Stream 20.png
Data Streaming pane Opens Data Streaming pane for configuring the streaming properties.
Toolbar Log 20.png
Status Log Opens the Status Log for monitoring the activity.
Toolbar Views 20.png
View Pane Adds extra View panes.
ToolBar ReferenceView 20.png
Reference View Pane Opens the view pane for monitoring reference videos with assets overlay.

Command Bar[edit]


File[edit]

Options under the File tab.

Open: Prompts user to select a file to open. Applicable files include Take files (.tak), Project files (.ttp deprecated), Camera Calibration files (.cal), Rigid Body definitions (.tra), Skeleton defintions (.skl).

Save Current Take: Saves currently opened Take.

Save Current Take As: Prompts the user to select a filename and a directory to save the current Take.

Save All Takes: Save all Takes from all of the sessions loaded in the Data Management pane.


Save Profile...: Saves the current software configurations onto the default application profile (XML). Which is located under C:\ProgramData\OptiTrack\MotiveProfile.xml.

Save Profile As...: Exports the current software configurations into an application profile (XML).

Load Profile...: Loads the Profile file for importing software configurations.

Info2.png

Profile files: Profile (XML) file stores software configurations in Motive. Saved items include applications settings, streaming setting, trackable assets, synchronization configurations, device configurations, and more. This file can be exported and imported to persist overall configurations in Motive.


Export Tracking Data: Exports tracking data from a selected Take into desired output format.


Add Session Folder... Adds session folder to the Data Management pane.

Import Shot List: Import a list of Take names to record from a CSV file that contains Take names on each row

Export Camera Calibration: Exports the current system calibration file(.cal) to a desired location.

Export Rigid Bodies: Exports selected rigid body assets(.tra) to a desired location.

Export Skeletons: Exports selected skeleton assets(.skl) to a desired location.

Export Video: Exports reference video to an AVI file. To play this file in Windows Media Player, a codec needs to be installed.


Recent Files: Displays a list recently opened Take files. This list will display the director of the recent files.


Exit: Closes the Motive application.

Edit[edit]

Options under the Edit tab.

Undo: Reverts data processing actions (i.e. deleting data, merging markers, filling gaps).

Redo: Reverts an Undo.


Trim Current Take: Archives the original take file and crops out the working range selected in the Graph View pane. For more information, read through the Trimming Captured Takes.


Application Settings: Opens the Application Settings pane.

Mouse Controls: Opens Mouse Controls pane for configuring mouse controls.

Hotkeys: Opens the Hotkey Editor pane for configuring custom Hotkeys

Reset Application Defaults: Sets all application settings to the default setting.

View[edit]

Options under the View tab.

Hide All Panes: This closes all of Motive's panes except the main viewport.


Devices pane: Opens Devices pane, or Cameras pane for Motive version 1.10 and below.

Camera Calibration: Opens the Calibration pane for calibrating the camera system.


Data Pane: Opens the Data Management pane for managing the recorded captures.

Assets Pane: Opens the Assets pane for managing the list of tracked assets as well as integrated devices such as force plates and data acquisition devices.

Properties Pane: Opens the Properties pane for managing the properties of selected items in Motive.


Rigid Body Pane: Opens the Rigid Body pane. This pane is used to configure the default creation properties for rigid body assets. Also, you can view real-time data and apply translation and rotation to selected assets.

Skeletons: Opens the Skeleton pane for creating a skeleton asset.

Markersets Pane: Opens the Markersets pane for managing selected markerset assets.


Timeline Pane: Opens the Timeline pane.

Edit Tools Pane: Opens the Edit Tools pane.

Labeling Pane: Opens the Labeling Pane.


Graph 1 & Graph 2: Opens Graph View pane for monitoring the channel data.


Data Streaming: Opens the Data Streaming pane.

Status Log: Opens the Status Log.


Dockable Viewports: Opens additional viewports.


Reference Overlays: Opens a Reference View window which displays and overlays the 2D view from the selected reference camera.


Toolbar: Toggles display of the Toolbar on/off.

Layout[edit]

Options under the Layout tab.

Warning2.png

Note: Layout configurations from previous versions of Motive cannot be loaded in Motive 2.0. Please re-create and update the layouts for use.

Calibrate: Displays panes applicable to system calibration. (Cameras, Perspective View, Camera Preview, Camera Calibration, Reconstruction)

Create: Displays panes applicable to asset creation and modification. (Project, Perspective View, Timeline, Skeleton, Rigid Bodies)

Capture: Displays panes applicable to capturing a take. (Project, Perspective View, Timeline)

Edit: Displays panes applicable to editing a take. (Project, Perspective View, Timeline, Edit Tools).


Create Layout: Saves the current layout. Saved custom layouts can be accessed from the drop-down menu located at the top-right corner of Motive.

Delete Layout: Deletes the saved custom layout.

Update Current: Updates the selected custom layout from the drop-down menu located at the top-right corner of Motive.

Set as Default: Sets the current layout as a default layout setup for starting Motive.


Label Fix, Skeleton Label: Custom layouts that are created by the user.

Tools[edit]

Options under the Tools tab.

Trackables: Opens the Trackables pane which contains

Measurements: Opens the Measurement pane which contains the Volume Accuracy tool for measuring the accuracy and the Probe tool for probe measurements.

Coordinate System Tools: (For Tracking Bars only) Opens the Coordinate System Tools pane, which replaces the ground plane tools for Duo/Trio Tracking bars.

Synchronization: Opens the Synchronization pane for Synchronization Configurations.

Audio Settings: Opens the Audio Capture and Playback Settings panel which allows you to select and test audio input/output devices.

Community[edit]

Options under the Community tab.

Ask A Question: Opens the NaturalPoint forums in a web browser where you can ask any question and get answers.

Tutorial & Training Videos: Opens the OptiTrack Wiki.

Submit Feedback: Opens a dialog box where you may submit any comments you have.

OptiTrack Products Catalog: Opens the OptiTrack online product catalog in a web browser.

Support Forums: Opens NaturalPoint's support forum.

Help[edit]

Options under the Help tab.

OptiTrack Support: Opens the OptiTrack support site.

News: Opens NaturalPoint's news feed.

Batch Processing Help: Opens the wiki documentation page on the Motive Batch Processor.

Check For Updates: Use this if you want to learn more about upgrading Motive.

Show Quick Start: Links you to our Quick Start Guide.

Startup News Check: This is a toggle for receiving notifications for Motive updates.


Licence Folder: Opens the folder location of your license files.

Application Folders: Opens the Application Folders pane that provides easy access to folders related to Motive.

About Motive: Displays information about the version of Motive currently running.