Motive 2.1 beta is now available. Please go to the 2.1 wiki for instructions on version 2.1:

Link

Motive Basics


Main PageMotive DocumentationMotive Basics

Page Scope

Before diving into specific details, let’s begin with a brief overview of Motive. If you are new to using Motive, we recommend you to read through this page and learn about the basic tools, configurations and navigation controls, as well as instructions on managing capture files.

File Management[edit]


Motive Data Management Pane
Windows File Explorer

In Motive, the recorded mocap data is stored in a file format called Take (TAK), and multiple Take files can be grouped within a session folder. The Data Management pane is the primary interface for managing capture files in Motive. This pane can be accessed from the Toolbar Data Icon.png icon on the main toolbar, and it contains a list of session folders and the corresponding Take files that are recorded or loaded in Motive.

Motive will save and load Motive-specific file formats including the Take files (TAK), Profile XML files (XML), Calibration files (CAL), and asset definition files for skeletons and rigid bodies (SKL and TRA). Asset definitions are related to trackable objects in Motive, and it will be explained more in the Rigid Body Tracking and Skeleton Tracking page.

Take File (TAK)[edit]

Motive file management is centered on the Take (TAK) file. A TAK file is a single motion capture recording (aka 'take' or 'trial'), which contains all the information necessary to recreate the entire capture from the file, including camera calibration, camera 2D data, reconstructed and labeled 3D data, data edits, solved joint angle data, tracking models (Skeletons, RigidBodies), and any additional device data (audio, force plate, etc). A Motive Take (TAK) file is a completely self-contained motion capture recording, and it can be opened by another version of Motive on another system.

Session Folders[edit]

A Session is a file folder that allows the user to organize multiple similar takes (e.g. Monday, Tuesday, Wednesday, or StaticTrials, WalkingTrials, RunningTrials, etc). Whether you are planning the day's shoot or incorporating a group of Takes mid-project, creating session folders can help manage complex sets of data. In the Data Management pane, you can import session folders that contain multiple Takes or create a new folder to start a new capture session. For a most efficient workflow, plan the mocap session before the capture and organize a list of captures (shots) that need to be completed. Type Take names in a spreadsheet or a text file, and Copy and paste the list, which will automatically create empty Takes (shot list) with corresponding names from the pasted list.

Application Profile (XML)[edit]

Software configurations are saved onto the Profile XML files. All of the application-related configurations, lists of assets, and the loaded session folders are preserved using this file format, and you can export and import the profiles to easily maintain the same software configurations each time Motive is launched.

All of the currently configured software settings will get saved onto the C:\ProgramData\OptiTrack\MotiveProfile.xml file periodically throughout capture and when closing out of Motive. This file is the default application profile and it gets loaded back when Motive is launched again. The containing folder can also be accessed through Help → Application Folders → Persistent Setting. This allows all of the configurations to be persisted in between different sessions of Motive. If you wish to revert all of the settings to its factory default, use the Reset Application Settings button under the Edit tab of the main command bar.

Profile XML files can also be exported and imported from the File menu of the main command bar in Motive. Using the Profile files, you can easily persist Motive configurations among different instances and different computers.

The following configurations get saved to application profile:

  • Application Settings. Including the Live-Reconstruction settings
  • Camera settings
  • Rigid Body & Skeleton asset definitions, and their corresponding properties.
  • Data streaming settings
  • Synchronization settings
  • Peripheral device settings (Force plates and NI-DAQ).
  • Data export settings
  • Labeling settings


Info2.png

What happened to the Project TTP Files?

The TTP project file format is deprecated starting from the 2.0 release. Now, recorded Takes will be managed by simply loading the session folders directly onto the new Data Management pane. For exporting and importing the software setting configurations, the Profile XML file format will replace the previous role of the TTP file. In the Profile XML files, software configurations such as reconstruction settings, application settings, data streaming settings, and many other settings will be contained. Camera calibration will no longer be saved in TTP files, but they will be saved in the calibration file (CAL) only.
TTP files can still be loaded in Motive 2.0. However, we suggest moving away from using TTP files.

Calibration files (CAL)[edit]

A calibration file is a standalone file that contains all required information to completely restore a calibrated camera volume; including positions and orientations of each camera as well as its lens distortion parameters. After a camera system is calibrated, CAL file can be exported and imported back again onto Motive when needed. Note that this file is reliable only if the camera setup has remained unchanged since the calibration. Read more from Calibration page.

Info2.png

Default System Calibration

The default system calibration gets saved onto the C:\ProgramData\OptiTrack\Motive\System Calibration.cal file, and it gets loaded automatically at application startup to provide instant access to the 3D volume. This file also gets updated each time calibration is modified or when closing out of Motive.

Viewports[edit]


Tutorial Video: 2D and 3D views in Motive

In Motive, the main viewport is fixed at the center of the UI, and this is used to monitor the 2D or 3D capture data in both live and edit mode. The Perspective View mode Viewport18.png shows the reconstructed 3D data within the calibrated 3D space, and the Camera Preview mode Viewport1.png shows 2D images from each camera in the setup. Both of these views are essential for assessing and monitoring the tracking data.

Perspective View - 3D viewport[edit]

  • Used to look through the reconstructed 3D representation of the capture, analyze marker positions, rays used in reconstruction, etc.
  • The context menu in the Perspective View allows you to access more options related to the markers and assets in 3D tracking data.


3D perspective view pane in Motive


Camera Preview - 2D view port[edit]

  • Each camera’s view can be accessed from the Camera Preview pane. It displays the images that are being transmitted from each camera. The image processing modes are displayed, including grayscale and object
  • Detected reflections are also shown in this pane, and reflections which satisfy the object filters and considered as markers
  • From Camera Preview pane, you can mask certain pixel regions to exclude them from the process.


2D Camera Preview

Basic Navigation Controls[edit]


Info2.png

Most of the navigation controls in Motive are customizable, including both mouse and Hotkey controls. The Hotkey Editor Pane and the Mouse Control Pane under the Edit tab allow you to customize mouse navigation and keyboard shortcuts to common operations.

View Port Mouse Control[edit]

Mouse Controls pane used to customize the navigation mouse controls.

Motive includes a variety of common mouse control preset 'profiles' so that any new users can easily start controling Motive. Available preset control profiles include Motive, Blade, Maya, and Visual3D. You can also open the Mouse Control pane under the Edit tab and customize the setting for your own preference.


Function Default Control
Rotate view Right + Drag
Pan view Middle (wheel) click + drag
Zoom in/out Mouse Wheel
Select in View Left mouse click
Toggle Selection in View CTRL + left mouse click

Hotkeys[edit]

Using the Hotkeys can speed up the workflows. All default hotkeys are listed in the Motive Hotkeys page. Hotkeys can also be customized from the Hotkey Editor (shown below), which can be accessed under the Edit tab in the Main Tool Bar. Various actions can be assigned with a custom hotkey using the Hotkey Editor.

For a list of the default Hotkey settings, read through the Motive Hotkeys Page.

Basics Hotkey 20.png

Control Deck[edit]


The Control Deck is always docked at the bottom of Motive, and it provides both recording and navigation controls over Motive's two primary operating modes: Live mode and Edit mode.

Live Mode

Control Deck in Live Mode.

Edit Mode

Control Deck in Edit Mode.

Live Mode and Edit Mode[edit]

In the Live Mode, all cameras are active and the system is processing camera data. If the mocap system is already calibrated, Motive is live-reconstructing 2D camera data into labeled and unlabeled 3D trajectories (markers) in real-time. The live tracking data can be streamed to other applications using the data streaming tools or the NatNet SDK. Also, in Live mode, the system is ready for recording and corresponding capture controls will be available in the Timeline Pane.

In the Edit Mode, the cameras are not active, and Motive is processing loaded Take file (pre-recorded data). In Edit Mode, playback controls will be available in the timeline pane, including access to the frame scrubber and the 2D Graph Editor for accessing and editing 3D trajectory data.

  • Live mode.
  • Edit Mode.

Graph View pane[edit]


The Graph View pane is used for plotting live or recorded channel data in Motive. For example, 3D coordinates of the reconstructed markers, 3D positions and orientations of rigid body assets, force plate data, analog data from data acquisition devices, and more can be plotted on this pane. You can switch between existing layouts or a create a custom layout for plotting specific channel data.

Basic navigation controls are highlighted below. For more information, read through the Graph View pane page.

Graph View in Motive

Basic Navigation Controls[edit]

On the Graph[edit]

Navigate Frames (Alt + Left-click + Drag)[edit]

Alt + left-click on the graph and drag the mouse left and right to navigate through the recorded frames. You can do the same with the mouse scroll as well.

Panning (Scroll-click + Drag)[edit]

Scroll-click and drag to pan the view vertically and horizontally throughout plotted graphs. Dragging the cursor left and right will pan the view along the horizontal axis for all of the graphs. When navigating vertically, scroll-click on a graph and drag up and down to pan vertically for the specific graph.

Zooming (Right-click + Drag)[edit]

Right-click and drag on a graph to free-form zoom in and out on both vertical and horizontal axis. If the Autoscale Graph Graph Autoscale 20.png is enabled, the vertical axis range will be fixed according to the max and min value of the plotted data.

Info2.png

Other Ways to Zoom:

  • Press "Shift + F" to zoom out to the entire frame range.
  • Zoom into a frame range by Alt + right-clicking on the graph and selecting the specific frame range to zoom into.
  • When a frame range is selected, press "F" to quickly zoom infto the selected range on the timeline.

Selecting Frame Range (Left-click + Drag)[edit]

The frame range selection is used when making post-processing edits on specific ranges of the recorded frames. Select a specific range by left-clicking and dragging the mouse left and right, and the selected frame ranges will be highlighted in yellow. You can also select more than one frame ranges by shift-selecting multiple ranges.

On the Navigation Bar[edit]

Navigate Frames (Left-click)[edit]

Left-click and drag on the nav bar to scrub through the recorded frames. You can do the same with the mouse scroll as well.

Pan View Range[edit]

Scroll-click and drag to pan the view range range.

Frame Range Zoom[edit]

Zoom into a frame range by re-sizing the scope range using the navigation bar handles. You can also easily do this by Alt + right-clicking on the graph and selecting a specific range to zoom into.


Navigation Bar[edit]

Navigation bar at the bottom of the Graph View pane.

Working Range / Playback range[edit]

The working range (also called the playback range) is both the view range and the playback range of a corresponding Take in Edit mode. Only within the working frame range, recorded tracking data will be played back and shown on the graphs. This range can also be used to output a specific frame ranges when exporting tracking data from Motive.

The working range can be set from different places:

  • In the navigation bar of the Graph View pane, you can drag the handles on the scrubber to set the working range.
  • You can also use the navigation controls on the Graph View pane to zoom in or zoom out on the frame ranges to set the working range.
  • Start and end frames of a working range can also be set from the Control Deck when in the Edit mode.

Selection Range[edit]

The selection range is used to apply post-processing edits only onto a specific frame range of a Take. Selected frame range will be highlighted in yellow on both Graph View pane as well as Timeline pane.

Gap indication[edit]

When playing back a recorded capture, the red colors on the navigation bar indicate the amount of occlusions from labeled markers. Brighter red means that there are more markers with labeling gaps.

Application Settings[edit]


The Application Settings can be accessed under the Edit tab or by clicking the Tb4.png icon on the main toolbar.

This pane is used for configuring application-wide settings, which include startup configurations, display options for both 2D and 3D viewports, settings for asset creation, and lastly, parameters for the Point Cloud Reconstruction engine. Read and find more about available preference settings from the Application Settings Pane page.

Info2.png

If you wish to reset the default application setting, go to Reset Application Settings under the Edit tab.

Reconstruction Settings[edit]

Under the Reconstruction tab, you can configure Point Cloud Reconstruction engine. The Reconstruction settings are one of the most important settings in Motive. These settings determine how 3D coordinates are acquired from the captured 2D camera images. Thus, understanding these settings is very important for optimizing the system for best tracking results.
For more information, read through the Application Settings page and the Reconstruction and 2D Mode

Layouts[edit]


The UI layout in Motive is customizable. All panes can be docked and undocked from the UI. Each pane can be positioned and organized by drag-and-drop using the on-screen docking indicators. Panes may float, dock, or stack. When stacked together, they form a tabbed window for quickly cycling through. Layouts in Motive can be saved and loaded, allowing a user to switch quickly between default and custom configurations suitable for different needs. Motive has preset layouts for Calibration, Creating a Skeleton, Capturing (Record), and Editing workflows. Custom layouts can be created, saved, and set as default from the Main Menu -> 'Layout' menu item. Quickly restore a particular layout from the Layout menu, the Layout Dropdown at the top right of the Main Menu, or via HotKeys.

Warning2.png

Note: Layout configurations from older versions cannot be loaded in Motive 2.0. Please re-create and update the layouts for use.

  • Docking indicator
  • Motive layout options
  • Layout features overview.



Back: Motive Documentations

Next: Capture Setup