Graph View pane


Back To Page References

New in Motive 2.0


Info2.png

This pane replaces the graph viewport from the Timeline pane in previous releases.


Scope

The Graph View pane is used to visualize the tracking data in Motive. This pane can be accessed from the command bar (View tab > Graph) or simply by clicking on the GraphViewIcon 111.png icon. This page provides instructions and tips on how to efficiently utilize the Graph View pane in Motive.


Overview[edit]


Using the Graph View pane, you can visualize and monitor multiple data channels including 3D positions of reconstructed markers, 6 Degrees of Freedom (6 DoF) data of trackable assets, and signals from integrated external devices (e.g. force plates or NI-DAQ). Graph View pane offers a variety of graph layouts for the most effective data visualization. In addition to the basic layouts (channel, combined, gapped), custom layouts can also be created for monitoring specific data channels only. Up to 9 graphs can be plotted in each layout and up to two panes can be opened simultaneously in Motive.

Graphs can be plotted in both Live and Edit mode.

  • In Live Mode, the following data can be plotted in real-time:
- Rigid body 6 DoF data (Position and Orientation)
- Force Plate Data (Force and Moment)
- Analog Data
  • In Edit Mode, the graphs can be used to review and post-process the captured data:
- 3D Positions of reconstructed markers
- Rigid body 6 DoF data (Position and Orientation)
- Force Plate Data (Force and Moment)
- Analog Data
Graph View pane in Motive.

Toolbar[edit]

Graph view toolbar.
Icon Name Description
Graph Editor 20.png
Graph Editor This opens up the sidebar for customizing a selected graph within a layout.
Graph Autoscale 20.png
Autoscale Graph Toggle to autoscale X/Y/Z graphs
Timeline Recenter.png
Zoom Fit

(selected range)

Zooms into selected frame region and centers the timeline accordingly
Graph LockCenter 20.png
Lock Cursor Centered Locks the timeline scrubber at the center of the view range.
Graph Delete 20.png
Delete Selected Keys Delete selected frame region.
View3D TranslateMode.png
Move Selected Keys Translates trajectories in selected frame region. Select a range and drag up and down on a trajectory.
Timeline DrawKeys.png
Draw Keys Manual draw trajectory by clicking and dragging on a selected trajectory in the Editor.
Graph MergeUp 20.png
Merge Keys Up Merges two two trajectories together. This feature is useful when used with the Tracks View graphs. Select two trajectories and click this button to merge the top trajectory into the bottom trajectory.
Graph MergeDown 20.png
Merge Keys Down Merges two two trajectories together. This feature is useful when used with the Tracks View graphs. Select two trajectories and click this button to merge the bottom trajectory into the top trajectory.
Graph SelectionLock 20.png
Lock Selection Locks the current selection (marker, rigid body, skeleton, force plates, or NI-DAQ) onto all graphs on the layout. They are used to temporarily hold the selections. Locked selections can later be fixed by taking a snapshot of the layout. This is elaborated more in the later section.

Pane Menu Options[edit]

Graph View pane menu

Create Layout[edit]

Creates a new graph layout.

Delete Layout[edit]

Deletes current graph layout.

Update Layout[edit]

Saves the changes to the graph layout XML file.

Particularize Layout[edit]

Takes an XML snapshot of the current graph layout. Once a layout has been particularized, both the layout configuration and the item selection will be fixed and it can be exported and imported onto different sessions.

Edit Layout[edit]

Opens the layout XML file of the current graph layout for editing.

Show Layout[edit]

Opens the file location of where the XML files for the graph layouts are stored.

Graph Navigation[edit]


Basic Navigation[edit]

On the Graph[edit]

Navigate Frames (Alt + Left-click + Drag)[edit]

Alt + left-click on the graph and drag the mouse left and right to navigate through the recorded frames. You can do the same with the mouse scroll as well.

Panning (Scroll-click + Drag)[edit]

Scroll-click and drag to pan the view vertically and horizontally throughout plotted graphs. Dragging the cursor left and right will pan the view along the horizontal axis for all of the graphs. When navigating vertically, scroll-click on a graph and drag up and down to pan vertically for the specific graph.

Zooming (Right-click + Drag)[edit]

Right-click and drag on a graph to free-form zoom in and out on both vertical and horizontal axis. If the Autoscale Graph Graph Autoscale 20.png is enabled, the vertical axis range will be fixed according to the max and min value of the plotted data.

Info2.png

Other Ways to Zoom:

  • Press "Shift + F" to zoom out to the entire frame range.
  • Zoom into a frame range by Alt + right-clicking on the graph and selecting the specific frame range to zoom into.
  • When a frame range is selected, press "F" to quickly zoom infto the selected range on the timeline.

Selecting Frame Range (Left-click + Drag)[edit]

The frame range selection is used when making post-processing edits on specific ranges of the recorded frames. Select a specific range by left-clicking and dragging the mouse left and right, and the selected frame ranges will be highlighted in yellow. You can also select more than one frame ranges by shift-selecting multiple ranges.

On the Navigation Bar[edit]

Navigate Frames (Left-click)[edit]

Left-click and drag on the nav bar to scrub through the recorded frames. You can do the same with the mouse scroll as well.

Pan View Range[edit]

Scroll-click and drag to pan the view range range.

Frame Range Zoom[edit]

Zoom into a frame range by re-sizing the scope range using the navigation bar handles. You can also easily do this by Alt + right-clicking on the graph and selecting a specific range to zoom into.

Navigation Bar[edit]

Navigation bar at the bottom of the Graph View pane.

Working Range / Playback range[edit]

The working range (also called the playback range) is both the view range and the playback range of a corresponding Take in Edit mode. Only within the working frame range, recorded tracking data will be played back and shown on the graphs. This range can also be used to output a specific frame ranges when exporting tracking data from Motive.

The working range can be set from different places:

  • In the navigation bar of the Graph View pane, you can drag the handles on the scrubber to set the working range.
  • You can also use the navigation controls on the Graph View pane to zoom in or zoom out on the frame ranges to set the working range.
  • Start and end frames of a working range can also be set from the Control Deck when in the Edit mode.

Selection Range[edit]

The selection range is used to apply post-processing edits only onto a specific frame range of a Take. Selected frame range will be highlighted in yellow on both Graph View pane as well as Timeline pane.

Gap indication[edit]

When playing back a recorded capture, the red colors on the navigation bar indicate the amount of occlusions from labeled markers. Brighter red means that there are more markers with labeling gaps.

Frame Range Selection[edit]

GraphView SelectedRange 111.png

Left-click and drag on the graph to select a specific frame range. Frame range selection can be utilized for the following workflows:

  • Zooming: Zoom quickly into the selected range by clicking on the Timeline Recenter.png button or by using the F hotkey.
  • Tracking Data Export: Exporting tracking data for selected frame ranges.
  • Reconstruction: Performing the post-processing reconstruction (Reconstructing / Reconstruct and Auto-labeling) pipeline on selected frame ranges.
  • Labeling: Assigning marker labels, modifying marker labels, or running the auto-label pipeline on selected ranges only.
  • Post-processing data editing: Applying the editing tools on selected frame ranges only. Read more: Data Editing
  • Data Deleting: Deleting 3D data or marker labels on selected ranges.

Layouts[edit]


  • Layout options
  • Context menu

The layouts feature in the Graphs View pane allows users to organize and format graph(s) to their preference. The graph layout is selected under the drop-down menu located at top-right corner of the Graph View pane.

In addition to default graph layouts (channels view, combined view, and tracks view) which have been migrated from the previous versions of Motive, custom layouts can also be created. With custom layouts, users can specify which data channels to plot on each graph, and up to 9 graphs can be configured on each layout. Furthermore, asset selections can be locked to labeled markers or assets.

System Layouts[edit]

Info2.png

Layouts under the System Layouts category are the same graphs that existed in the old timeline editor.

Channel View[edit]

The Channel View provides X/Y/Z curves for each selected marker, providing verbose motion data that highlights gaps, spikes, or other types of noise in the data.

System Layouts: Channel View

Combined View[edit]

The Combined View provides X/Y/Z curves for each selected markers at same plot. This mode is useful for monitoring positions changes without having to translate or rescale the y-axis of the graph.

System Layout: Combined View

Tracks View[edit]

The Tracks View is a simplified view that can reveal gaps, marker swaps, and other basic labeling issues that can be quickly remedied by merging multiple marker trajectories together. You can select a specific group of markers from the drop down menu. When two markers are selected, labels can be merged by using Timeline MergeDown.png and Timeline MergeUp.png.

System Layout: Tracks View

Custom Layouts[edit]

In the new Graphs View pane, the graph layout can be customized to monitor data from channels involved in a capture. Create a new layout from the ContextMenu dotdotdot.png menu > Create New Layout option or right-click on the pane and click Create New Layout option.

Graph layout customization is further explained on the later section: Customizing Layout.

Customizing Graph Layout[edit]


General Steps[edit]

Choosing desired number of rows and colums on a newly created layout

Step 1. Create New Layout[edit]

New layouts can be created by clicking on the Create Graph Layout from the pane menu ContextMenu dotdotdot.png located on the top-right corner.

Step 2. Set the number of graphs[edit]

Right-click on the graph, go to the Grid Layout, and choose the number of rows and columns that you wish to put in the grid. (max 9 x 9)

Step 3. Open the Graph Editor[edit]

Data Editor in the Graph View pane.
Expand the Graph Editor by clicking on the Graph Editor 20.png icon on the tool bar.

Step 4. Select a graph[edit]

Click on a graph from the grid. The graph will be highlighted in yellow. Within the grid, only the selected graph will be edited when making changes using the Graph Editor.

Step 5. Pick Data Channels[edit]

Next, you need to pick data channels that you wish to plot. You can do this by checking the desired channels under the data tab while a graph is selected. Only the checked channels will be plotted on the selected graph.

Step 6. Format visuals[edit]

Then under the Visual tab, format the style of the graph. You can configure the graph axis, assign name for the graph, display values, and etc. Most importantly, configure the View Style to match desired graph format.

Info2.png

When plotting live tracking data in the Live Mode, set the View Style to Live.

Step 7. Repeat[edit]

Repeat the above steps 5 ~ 6 and configure each of the graphs in the layout.

Step 8. Make selection[edit]

Select an asset (marker, rigid body, skeleton, force plate, or NI-DAQ channel) that you wish to monitor.
The lock symbol indicates the selection has been locked on the graph.

Step 9. Lock selection to graph(s)[edit]

Lock selection for graphs that needs to be linked to the selection. Individual graphs can be locked from the context menu (right-clicking on the graph > Lock Selection) or all graphs can be locked by clicking GraphView LockSelection 20.png on the toolbar.

Step 10. Repeat lock selection[edit]

Once all related graphs are locked, move onto next selection and lock the corresponding graphs.

Step 11. Update the layout[edit]

When you have the layout configured with the locked selections you can save the configurations as well as the implicit selections temporarily to the layout. Until the layout is particularized onto the explicit selections, you will need to select the related items in Motive to plot the respective graphs.

Step 12. Particularize the layout[edit]

The last step is to make the selection explicit by particularizing the layout Viewport3.png. You can do this by clicking the Particularize option under the pane menu once the layout is configured and desired selections are locked. This will fix the explicit selection onto the layout XML file, and the layout will always look for specific items with the same name from the Take. Particularized graphs will be indicated by GraphView ParticularizedIcon 20.png at the top-right corner of the graph.
Particularized graph. Fz force data from OR6-7-1000 plate, explicitly, will be plotted on the graph

Particularizing a Layout[edit]

It is important to particularize the customized layout once all of the graphs are configured. This action will save and explicitly fix the locked selections that the graphs are locked onto. Once the layouts have been particularized, you can re-open the same layout on different sessions and plot the data channels from the same subject with out locking the selection again. Specifically, the particularized layout will try to look for items (labeled marker, rigid body, skeleton, force plate, or analog channels) with the same names that the layout is particularized onto.

Graph Editor Sidebar[edit]


The Graph Editor can be expanded by clicking on the Graph Editor 20.png Icon from the toolbar. When this sidebar is expanded, you can select individual graphs but other navigation controls will be disabled. Using the graph editor, you can select a graph, choose which data channels to plot, and format the overall look to suit your need.

Data tab[edit]

GraphView Edit Data 111.png

Only enabled, or checked, data channels will be plotted on the selected graph. Once channels are enabled, an asset (marker, rigid body, skeleton, force plate, or DAQ channel) must be selected and locked.

Marker[edit]

Plot 3D position (X/Y/Z) data of selected, or locked, marker(s) onto the selected graph.

Rigid Body[edit]

Plot pivot point position (X/Y/Z), rotation (pitch/yaw/roll), or mean error values of selected, or locked, rigid body asset(s) onto the selected graph.

Device[edit]

Plot analog data of selected analog channel(s) from a data acquisition (NI-DAQ) device onto the selected graph.

Force Plate[edit]

Plot force and moment (X/Y/Z) of selected force plate(s). Plotted graph respects coordinate system of the force platforms (z-up).

Visual tab[edit]

GraphView Edit Visual 111.png

Graph Name[edit]

Labels the selected graph.

View Style[edit]

Configures the style of the selected graph:
  • Channel: Plots selected channels onto the graph.
  • Combined: Plots X/Y/Z curves for each selected markers fixed on the same plot.
  • Gap: The Tracks View style allows you to easily monitor the occluded gaps on selected markers.
  • Live: The Live mode is used for plotting the live data.

Range Handles[edit]

Enables/disables range handles that are located at the bottom of the frame selection.

Row Stretch[edit]

Sets the height of the selected row in the layout. The height will be determined by a ratio to a sum of all stretch values: (row stretch value for the selected row)/(sum of row stretch values from all rows) * (size of the pane).

Colum Stretch[edit]

Sets the width of the selected column in the layout. The width size will be determined by a ratio to a sum of all values: (column stretch value for the selected column)/(sum of column stretch values from all columns) * (size of the pane).

Show Values[edit]

Display current frame values for each data set.

Show Labels[edit]

Display name of each ploted data set.

Show Primary Selection Only[edit]

Plots data from the primary selection only. The primary selection is the last item selected from Motive.

Show X Grid[edit]

Shows/hides x grid-lines.

Show Y Grid[edit]

Shows/hides y grid-lines.

Major Y[edit]

Sets the size of the major grid lines, or tick marks, on the y-axis values.

Minor Y[edit]

Sets the size of the minor grid lines, or tick marks, on the y-axis values.

Min Y[edit]

Sets the minimum value for the y-axis on the graph.

Max Y[edit]

Sets the maximum value for the y-axis on the graph.