Motive 2.1 beta is now available. Please check the documentation versions on the sidebar.

Data Management pane


Main page

New in Motive 2.0


Page Scope

The Data Management pane is used for managing the Take files. This pane can be accessed under the View tab in Motive or by clicking Toolbar Data Icon.png icon on the main toolbar.

Overview[edit]


DataManagementPane Overview.png

Pane menu[edit]

Data management pane options.
Option Description
Simple Use a simplest data management layout.
Advanced Additional column headers are added to the layout.
Classic Use the classic Motive layout where Take name, availability of 2D data and 3D data is listed.
New... Create a new customizable layout.
Rename Rename a custom layout.
Delete Delete a custom layout.
2D Mode In the Edit mode, when this option is enabled, Motive will access the recorded 2D data of a current Take. In this mode, Motive will be live-reconstructing from recorded 2D data and you will be able to inspect the reconstructions and marker rays from the view ports. For more information: Reconstruction and 2D Mode.
Import Shot List... Import a list of empty Take names from a CSV file. This is helpful when you plan a list of shots in advance to the capture.
Export Take Info... Exports a list of Take informations into an XML file. Included elements are name of the session, name of the take, file directory, involved assets, notes, time range, duration, and number of frames included.

List of Session Folders[edit]


List of loaded session folders. Current session folder is denote with a flag icon

The left-hand section of the Data Management pane is used to list out the sessions that are loaded in Motive. Session folders group multiple associated Take files in Motive, and they can be imported simply by dragging-and-dropping or importing IconAdd.png a folder into the data management pane. When a session folder is loaded, all of the Take files within the folder are loaded altogether.

In the list of session folders, a currently loaded session folder will be denoted with a flag symbol DataManagementPane Flag 111.png, and a selected session folder will be highlighted in white.

Action Items[edit]

  • IconAdd.png: Add a new session folder .
  • IconRemoveSession.png: Remove a session folder from the list or delete permanently.
  • CollapseSidebar.png:Collapse the session folder sidebar.

Info2.png

What happened to the Project TTP Files?

The TTP project file format is deprecated starting from the 2.0 release. Now, recorded Takes will be managed by simply loading the session folders directly onto the new Data Management pane. For exporting and importing the software setting configurations, the Profile XML file format will replace the previous role of the TTP file. In the Profile XML files, software configurations such as reconstruction settings, application settings, data streaming settings, and many other settings will be contained. Camera calibration will no longer be saved in TTP files, but they will be saved in the calibration file (CAL) only.
TTP files can still be loaded in Motive 2.0. However, we suggest moving away from using TTP files.

Context Menu Options[edit]

Context menu on session folders.

Set as Current[edit]

Set the selected session as the current session.

Rename[edit]

Rename the session folder.

Create Sub-folder[edit]

This creates a folder under the selected directory.

Show Folder Location[edit]

Opens the session folder from the file explorer

Delete[edit]

Delete the session folder. All of its contents will be deleted as well.

List of Takes[edit]


When a session folder is selected, associated Take files and their descriptions are listed in a table format on the right-hand side of the Data Management pane. For each Take, general descriptions and basic information are shown in the columns of the respective row. To view additional descriptions, click on the pane menu, select the Advanced option, and all of the descriptions will be listed. For each of the enabled columns, you can click on the arrow next to it to sort up/down the list of Takes depending on the category.

DataManagementPane Takes 111.png

Take Information[edit]

Category Description
Best The star mark DataManagement Healthy.png, allows users to mark the best Takes. Simply click on the star icon and mark the successful Takes.
Health The health status of the Takes indicates status of the takes
  • UI DM Health1.png : Good capture
  • UI DM Health2.png : Average capture
  • UI DM Health3.png : Poor capture
Progress The progress indicator can be used to track the process of the Takes. Use the indicators to track down the workflow specific progress of theTakes.
  • Ready
  • Recorded
  • Reviewed
  • Labeled
  • Cleaned
  • Exported
Name Shows the name of the Take.
2D Indicates whether 2D data exists on the corresponding Take
3D Indicates whether the reconstructed 3D data exists on the corresponding Take.

If 3D data does not exist on a Take, it can be derived from 2D data by performing the reconstruction pipeline. See Reconstruction page for more details.

Video Indicates whether reference videos exist in the Take. Reference videos are recorded from cameras that are set to either MJPEG grayscale or raw grayscale modes.
Solved Indicates whether any of the assets have solved data baked into it.
Audio Indicates whether synchronized audio data have been recorded with the Take. See: Audio Recording in Motive
Analog Indicates whether analog data recorded using a data acquisition device exists in the Take. See: NI-DAQ Setup page.
Data Recorded Shows the time and the date when the Take was recorded.
Duration Time length of the Take
Total Frames Total number of captured frames in the Take
Notes Section for adding commenting on each Take.

Search Bar[edit]

Searching for Takes that contains solved assets data.

A search bar is located at the bottom of the Data Management pane, and you can search a selected session folder using any number of keywords and search filters. Motive will use the text in the input field to list out the matching Takes from the selected session folder. Unless otherwise specified, the search filter will scope to all of the columns.

Search for exact phrase[edit]

  • Wrap your search text in quotation marks.
  • e.g. Search "shooting a gun" for searching a file named Shooting a Gun.tak.

Search specific fields[edit]

  • To limit the search to specific columns, type field:, plus the name of a column enclosed with quotation marks, and then the value or term you're searching for.
  • Multiple fields and/or values may be specified in any order.
  • e.g. field:"name" Lizzy, field:"notes" Static capture.

Search for true/false values[edit]

  • To search specific binary states from the Take list, type the name of the field followed by a colon (:), and then enter either true ([t], [true], [yes], [y]) or false ([f], [false], [no], [n]).
  • e.g. Best:[true], Solved:[false], Video:[T], Analog:[yes]

Customizing Table Layout[edit]

The table layout can also be customized. To do so, go to the pane menu and select New or any of the previously customized layouts. Once you are in a customizable layout, right-click on the top header bar and add or remove categories from the table.

  • List of layouts from the Data Management pane menu.
  • Customizing header categories.

Importing a List of Empty Takes[edit]

A list of take names can be imported from either a CSV file or carriage return texts that contain a take name on each line. Using this feature, you can plan, organize, and create a list of capture names ahead of actual recording. Once take names have been imported, a list of empty takes with the corresponding names will be listed for the selected session folder.

From a Text[edit]

Take lists can be imported by copying a list of take names and pasting them onto the Data Management pane. Take names must be separated by carriage returns; in other words, each take name must be in a new line.
DataManagementPane ImportingFromText.png

From a CSV File[edit]

Take lists can be imported from a CSV file that contains take names on each row. To import, click on the top-right menu icon (ContextMenu dotdotdot.png) and select Import Shot List.
DataManagementPane ImportingFromCSV.png

Take Menu[edit]


In the Data Management pane, context menu for captured Takes can be brought up by clicking on the ContextMenu dotdotdot.png icon or by right-clicking on a selected Take(s). The context menu lists out the options which can be used to perform corresponding pipelines on the selected Take(s). The menu contains a lot of essential pipelines such as reconstruction, auto-label, data export and many others. Available options are listed below.

Context Menu Options[edit]

Data Management pane context menu for a selected Take.

Save[edit]

Saves the selected take

Revert[edit]

Reverts any changes that were made. This does not work on the currently opened Take.

Make Current[edit]

Selects the current take and loads it for playback or editing.

Rename Take[edit]

Allows the current take to be renamed.

Reconstruct and Auto-label[edit]

Combines 2D data from each camera in the system to create a usable 3D take. It also incorporates assets in the Take to auto-label and create rigid bodies and skeletons in the Take. Reconstruction is required in order to edit or export the skeleton or the rigid body data in the Take.

Reconstruct[edit]

Separate reconstruction pipeline without the auto-labeling process. Reconstructs 3D data using the 2D data.

Auto-label[edit]

Separate auto-labeling pipeline that labels markers using the existing tracking asset definitions. Available only when 3D data is reconstructed for the Take.

Record Joint Angles[edit]

Solves marker data to joint angles (skeletal data) for the selected take.

Export Tracking Data[edit]

Opens the Export dialog window to select and initiate file export. Valid formats for export are CSV, C3D, FBX, BVH.

Export Video[edit]

Opens the export dialog window to initiate scene video export to AVI.

Export Audio[edit]

Exports an audio file when selected Take contains audio data.

Show File Location[edit]

Opens an explorer window to the current asset path. This can be helpful when backing up, transferring, or exporting data.

Delete 2D Data[edit]

Opens the Delete 2D Data pop-up where you can select to delete the 2D data, Audio data, or reference video data. Read more in Deleting 2D data.

Delete 3D Data[edit]

Permanently deletes the 3D data from the take. This option is useful in the event reconstruction or editing causes damage to the data.

Delete Marker Labels[edit]

Unlabels all existing marker labels in 3D data. If you wish to re-auto-label markers using modified asset definitions, you will need to first unlabel markers for respective assets.

Delete Joint Angle Data[edit]

Permanently deletes the joint angle data from the take.

Archive Take[edit]

Archives the original take file and creates a duplicate version, minus any 2D data. Archiving a take will reduce size of the active take file while preserving the 2D camera data in a backup sub-directory for later use, if necessary.

Remove from Project[edit]

Closes the take and removes it from the project pane.

Delete Take Permanently[edit]

Opens a dialog box to confirm permanent deletion of the take and all associated 2D, 3D, and Joint Angle Data from the computer. This option cannot be undone.

Move Assets to Take[edit]

Copies the assets from the current capture to the selected Takes.